Back to overview
Resolved
DDoS Attack on all services
Sep 17, 2026 at 7:35pm UTC
Affected services
Main Site
REST API
Argus Latch
Resolved
Sep 17, 2026 at 8:00pm UTC
The DDoS attack has been resolved.
Affected services
Updated
Sep 17, 2026 at 7:45pm UTC
Under attack mode has been enabled, and the DDoS attack has slowed down.
Affected services
Created
Sep 17, 2026 at 7:35pm UTC
We are currently investigating and mitigating an active DDoS attack on our services. Downtime is not expected, though our services will have latency.
Affected services